WebGL Pitfalls And How To Fix Them

André Michelle

With the latest update , we introduced (link is only visible to registered users) to render the devices and the cables. Even though (link is only visible to registered users) is supposed to be way faster for this task than the CPU, many users report a performance slowdown. Unfortunately this did not pop up in our internal beta.

Hardware Acceleration Not Activated In Chrome (Poor Performance)

As described here:

  • (link is only visible to registered users)

Solution:

  • Please follow this (link is only visible to registered users) to activate hardware acceleration in Chrome. Thanks aeiter
  • Update your graphics card drivers: (link is only visible to registered users)

Panic (Nothing Helps)

If nothing helps, please post your system configuration (OS, browser, GPU model). In addition, copy and paste chrome://gpu/ into the address bar in Chrome and copy and paste the result of only the first paragraph: Graphics Feature Status.

Ideally, it should looks like this:

Graphics Feature Status

  • Canvas: Hardware accelerated
  • Flash: Hardware accelerated
  • Flash Stage3D: Hardware accelerated
  • Flash Stage3D Baseline profile: Hardware accelerated
  • Compositing: Hardware accelerated
  • Multiple Raster Threads: Enabled
  • Native GpuMemoryBuffers: Hardware accelerated
  • Out-of-process Rasterization: Disabled
  • Hardware Protected Video Decode: Unavailable
  • Rasterization: Hardware accelerated
  • Skia Renderer: Disabled
  • Surface Control: Disabled
  • Surface Synchronization: Enabled
  • Video Decode: Hardware accelerated
  • Viz Service Display Compositor: Enabled
  • WebGL: Hardware accelerated
  • WebGL2: Hardware accelerated

Please don't forget to describe your problem briefly.

Create an account or Login to write a comment.

  • User Avatar

    caleb77777

    hey when i try to play my drafts in tracks my brave web browser says 404 though and the sound doesn't play at all. whats going on and why did i forget to record or something else audiotool family.

  • User Avatar

    eratekk

    Hi, I have pretty bad GPU usage. Its constantly at 97% while working in the app (desktop).

    Windows 10

    Chrome

    geforce 940mx

    Canvas: Hardware accelerated

    Canvas out-of-process rasterization: Disabled

    Compositing: Hardware accelerated

    Multiple Raster Threads: Enabled

    Out-of-process Rasterization: Hardware accelerated

    OpenGL: Enabled

    Rasterization: Hardware accelerated

    Raw Draw: Disabled

    Skia Renderer: Enabled

    Video Decode: Hardware accelerated

    Vulkan: Disabled

    WebGL: Hardware accelerated

    WebGL2: Hardware accelerated

    • User Avatar

      Vulkron

      ive been experiencing the same thing actually. All of these settings are the same on my pc except my graphics card is a geforce gtx 1650

  • User Avatar

    awreadyiceykoo_cj_gmail_com

    how do you stop a overload

  • User Avatar

    ofvmusic ‏‏‎‎

    How can I enable some of the "graphic feature status"?

    • User Avatar

      ofvmusic ‏‏‎‎

      I've used a flag on chrome://flags/ thank u :)

    • User Avatar

      kurp

      oH how to activate them. I'm sure you can do this in your Nvidia graphics card settings but not sure about intel or radeon, a quick google search is an easy fix

    • User Avatar

      kurp

      chrome://gpu/

  • User Avatar

    André Michelle

    Update: The rendering glitches are now fixed.

  • User Avatar

    Moderator

    add to sticky

  • User Avatar

    kurp

    New features, new bugs! (:

00:00
06:03