RisingFlames

audiotool next first requires version 63

  • 1 week ago
  • 1
  • 0

audiotool next first requires version 63

i have chrome 63 but it keeps saying it

Create an account or Login to write a comment.

  • User Avatar

    Known As I

    1 week ago

    Maybe the message is misleading about the version that is really required.

    Why not just update to the current version? Version 71.0.3578.80 (Official Build) (64-bit) works fine.

00:00
06:03